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SalesOutlook Client Installation Checklist

Please complete the steps below, in the order listed, to install and configure SalesOutlook on a desktop, tablet, or notebook computer.  The settings and processes described below offer the “best” (the best performance and most reliable, trouble-free) experience for SalesOutlook users.
· Have your SalesOutlook / Exchange Administrator ensure that the User Login Name above is added to the SalesOutlook Setup form’s License Key tab, and have the Exchange Admin make note of the exact format of the user’s Email Display Name and document it in the space provided above.  If you do not have a SalesOutlook database set up on your Exchange Server, please have your Exchange Administrator refer to the SalesOutlook Administration Guide in the SalesOutlook Documentation Set for instructions covering how to install, configure and secure the shared SalesOutlook database within your Exchange Server’s All Public Folders tree.
· Ensure that the latest service packs and updates for the Windows operating system are installed.
· If Windows XP SP2 or later is not installed, if not then download and install the Microsoft Jet 4.0 Database SP8 and MDAC 2.8 updates from www.microsoft.com/downloads.
· Use Add/Remove Programs and customize the Microsoft Office installation.  Ensure that, at the minimum, the Collaborative Data Objects (CDO) and the Microsoft Query application components are installed.  Also, the Jet ISAM drivers for Outlook and Exchange must be installed in order for SalesOutlook to operate properly.  In most cases, it is best to do a “full install” of all available Microsoft Office components with the exception of Microsoft Business Contact Manager.  Microsoft Business Contact Manager can co-exist with SalesOutlook in an Outlook Profile but it is not recommended.
· Visit the Office Update website at www.microsoft.com/office and apply the latest service pack and updates for all installed Microsoft Office and Microsoft Office System applications.  Please note that in some instances the original installation media will need to be available in order to install service packs and updates.  Additionally, the installation of service packs and updates may fail if the core Microsoft Office applications (Word, Excel, Outlook, PowerPoint and Access) are not all the same version of Microsoft Office.  If this is the case, download and use the “Administrative Install” for the service pack.
· Do the following if you log into a Domain: Ensure that the domain login account for the user listed above is a member of either the SalesOutlook Admins or the SalesOutlook Users group in Active Directory to grant permissions to the SalesOutlook folders within Exchange Public Folders.  Each individual using SalesOutlook should be a member of one or the other groups, but not both.  If these groups do not exist, please refer to the SalesOutlook Administration Guide for instructions on how to create these two mail-enabled Active Directory Security Groups.
· Do the following if you log in locally: Ensure that the domain login account for the user is a member of the Administrators group in the local computer’s “Users & Computers” management tool found under Administrative Tools in the Control Panel.  Users must have full admin rights to the local computer in order to install, update or uninstall the SalesOutlook software.
· If any version of the SalesOutlook Client is installed on the computer for any Windows user profile, the SalesOutlook application (along with any SalesOutlook Updates) run the SO_Outlook.reg file located under \Program Files\SalesOutlook\..
· If upgrading from any version of the SalesOutlook software prior to version 4.3 to SalesOutlook version 4.3 or later, install the SalesOutlook client and then use Add/Remove Programs to uninstall the SalesOutlook client software.  Uninstalling SalesOutlook 4.3 and later runs “cleanup” code that was not executed in previous versions of the SalesOutlook installation programs.  If you uninstalled the 4.3 or later client after installing it, please be sure to install the SalesOutlook client again before proceeding to the next step.
· Ensure the computer is plugged into the network and that you log in as the user who will be running SalesOutlook on this computer.  Use the login information provided at the beginning of this checklist.
· Install the SalesOutlook Client software while the .msi file resides on the local hard drive.  
· Microsoft Outlook users who are not constantly connected to the LAN and the Exchange Server using a 100MB or faster connection should be configured for offline use or to leverage the new Cached Exchange Mode available in Outlook 2003.  SalesOutlook does not recommend SalesOutlook users to work Online or Connected with the Exchange Server when working on broadband, dial-up or other connections that do not offer the full speed and performance of the LAN.
· If the user uses Microsoft Outlook 2003 with Cached Exchange Mode enabled:
· Ensure that the user does not have an Outlook Profile on any other machine that has Cached Exchange Mode enabled.  Microsoft Outlook supports only one set of cached / offline data per domain user login account.
· Configure the Outlook Profile so that the “Use Cached Exchange Mode” checkbox is checked (provided the user does not use Cached Exchange Mode or offline folders on any other computer or in any other Outlook Profile), and then click the “More Settings” button to reveal the Advanced Configuration Settings dialog window.  Otherwise, uncheck the Use Cached Exchange Mode checkbox.
· On the General tab, select the option to “Allow Outlook to Automatically Determine the Connection Type” ONLY if Outlook 2003 is configured to use Cached Exchange Mode.  Otherwise, select the option to “Manually Control the Connection Type” and select the option to “Work offline and use dial-up networking”.  
· Uncheck the checkbox that instructs Outlook to “Prompt for connection type” when Outlook is launched if Outlook 2003 is in Cached Exchange Mode.
· On the Advanced tab, check the checkbox to instruct Outlook to cache the Public Folder Favorites by placing a check in the option named “Download Public Folder Favorites.”
· Verify that the Offline data store is in the Unicode format.  If not, delete the *.ost and *.oab files.  If upgrading from a previous version of Office or migrating to a new server, then also delete the Outlook Profile and create a new one.
· If the user DOES NOT use Microsoft Outlook 2003 in Cached Exchange Mode or uses a version of Microsoft Outlook older than Outlook 2003:
· Configure the Outlook Profile so that the “Use Cached Exchange Mode” checkbox is unchecked (Outlook 2003 users only), and then click the “More Settings” button to reveal the Advanced Configuration Settings dialog window.
· Select the option to “Manually Control the Connection Type” and select the option to “Work offline and use dial-up networking”.  
· If the user will work offline or travel with this computer, check the checkbox that instructs Outlook to “Prompt for connection type” when Outlook is launched.
· Click the OK button on the Advanced Configuration Settings dialog and then click the Finish button to close the Configure Email Accounts wizard.
· Launch Outlook and choose “Connect” when prompted so that Outlook is connecting directly to the Exchange Server over the LAN.
· Clear the Outlook Forms Cache by right-clicking the Inbox, select Properties > Forms > Manage > Clear Cache and then click OK until back at the main Outlook Explorer window.
· If Outlook 2003 in Cached Exchange Mode or an older version of Outlook where offline use will be enabled, navigate to the SalesOutlook folder in the All Public Folders tree.  With the SalesOutlook folder highlighted, click the File menu and then select the “Add to Favorites…” option found on the fly-out menu named “Folder”.  Please note that users who work online with the Exchange Server do not need and should not add the SalesOutlook Folders to Public Folder Favorites.
· In the Add To Favorites dialog, click the More Options button – this is VERY important.
· Check both checkboxes and select the bottom radio option under each of the two checkboxes.  
· Click the Add button only after ensuring that All Folders and Sub Folders will be automatically added to this Favorites tree no matter if they exist now or are added at some point in the future.

· If Outlook 2003 Cached Exchange Mode is enabled or if the computer will be configured for Offline use, click Tools > Send/Receive Settings > Define Send/Receive Groups.  This will enable you to define the synchronization settings so that Outlook will know which folders to maintain in the offline / cached database (outlook.ost file) on the local computer’s hard drive.  

· In the user’s mailbox, generall it is best to check all of the folders, but the Calendar, Contacts, Deleted Items, Drafts, Inbox, Sent Items, Outbox, and Tasks folders MUST be checked.  It is also recommended to check the various Synchronization Failures and Junk Email Folders so that they are also available offline.

· In the Public Folder Favorites portion of the Send/Receive Group settings, ensure that ALL of the SalesOutlook-related folders are flagged to be available offline.

· Check the checkbox named “Synchronize Forms” so that future updates to the SalesOutlook forms will be automatically distributed to the user’s offline database when published to the server.

· Set the Offline Address Book to synchronize Full Details.

· Ensure that Outlook ALWAYS synchronizes the Full Message and not only the Message Header.  SalesOutlook always requires the full message item and not just a portion of it.  By default, Outlook 2003 sets an option to download headers only on slower connections.  This setting is not supported.
· When all settings are configured, click OK to close the Define Send/Receive Groups dialog and then press <F9> on the keyboard to start building the offline database.  Outlook 2003 Cached Exchange Mode users should instead click on each SalesOutlook folder in the Public Folder Favorites to kick off the process that updates the folders.
· DO NOT CONTINUE TO THE NEXT STEP UNTIL ALL OFFLINE FOLDERS ARE FULLY UP TO DATE AND FULLY POPULATED WITH DATA.
· After the system is fully synchronized, close Outlook and shut down the computer by clicking Start > Shut Down.

· Do not unplug from the network if Outlook 2003 with Cached Exchange Mode enabled or if using an older version of Outlook that will always work online with the Exchange Server.  Otherwise, unplug the computer from the LAN.
· Turn on the computer and login to the domain as the user you are configuring.

· Modify the Outlook Profile’s connection settings as follows:

· If a desktop that will always work connected with the server using the LAN and is not Outlook 2003 in Cached Exchange Mode, change the connection type from “Work offline and use dial-up networking” to the “Allow Outlook to Automatically Determine the Connection State” option (if not already selected).

· If the computer is NOT a desktop that will always be connected to the Exchange Server, or if it is an Outlook 2003 computer configured to use the Cached Exchange Mode, uncheck the checkbox that instructs Outlook to prompt the user for the connection type.  
Note -- Only advanced Power Users and IT Admins who understand the implications of choosing a different connection type should be allowed to choose the connection type.  Each time the connection type is changed, the SalesOutlook client software will need to be reconfigured to work correctly with the new connection type.
· After adjusting the connection type setting as previously described, click OK to close the Advanced Configuration dialog and then click Finish to close the Email Account configuration wizard.

· Launch Outlook, or if already running be sure to fully exit Outlook and allow it to completely shut down and unload from memory before launching Outlook again.  Rebooting the computer ensures that Outlook fully closes.

· In Outlook, right click the user’s Inbox, select Properties, click the Forms tab, click the Manage button and then click the Clear Cache button to clear the Outlook Forms Cache.  Then, click the Close / Cancel button to close the Forms Manager window.  Note that this step does not need to be completed for computers where SalesOutlook has never been installed prior to this installation.
· If Outlook 2003 Cached Exchange Mode is enabled, or if this is a notebook computer or a Tablet PC running Outlook 2000 or Outlook XP enabled for offline use, ensure that Outlook indicates it is “Offline” in the lower right hand corner of the main Outlook window before proceeding to the next step.  
Tip -- Outlook 2003 Cached Exchange Mode users can click where Outlook says “Connected” in the lower right-hand corner and choose the option to Work Offline to switch to offline mode.  Note that users will need to be trained to use this option to “go offline” before disconnecting with the LAN and again to “Connect” when they return and plug back into the LAN.
· On the main Outlook menu, click Tools > Options > SalesOutlook Folder Settings tab.  On this tab, click the explorer button to the right of the Account Profiles field.  
· In the Pick Folder window that opens, navigate to the Account Profiles folder in the SalesOutlook folder structure.  
· Note that users who are configured to work offline or in Cached Exchange Mode should select the Account Profiles folder while Outlook is “Offline”, and these users MUST navigate the Public Folders via the Favorites tree at all times.  Therefore, offline users and cached exchange mode users must select the Account Profiles folder by navigating the Public Folder Favorites tree and not the All Public Folders tree.  
· Desktop users who do not work in the Cached Exchange Mode, including all users who work online with the Exchange Server at all times, should navigate the All Public Folders tree to select the Account Profiles folder.  Users who work Connected do not need Public Folder Favorites or the SalesOutlook folders defined within Send/Receive Groups since they are constantly connected to the LAN and the Exchange Server.
· Click the Address Book button to the right of the User Name field and select the user’s name from the Global Address Book.

· Click the OK button to save the settings, and click the Yes button when prompted to map the SalesOutlook database fields.  The SalesOutlook client will not work properly if the database field mapping does not complete successfully, and Offline users will encounter problems when they disconnect from the LAN if Outlook is not Offline when the mapping process executes.
· The SalesOutlook client is configured, so quickly test the Add/Action drop down, the Find Account and Find Contact buttons.

· Test the ability of the user to synchronize data from outside the corporate firewall by connecting to the Internet using a dial-up or other “external” connection method.  Then, click the Send/Receive Group that synchronizes email and the SalesOutlook data.  Note that this step can be skipped for users who work “connected” on the LAN at all times.  This step should be completed for users who work offline and for users who use Outlook 2003 in Cached Exchange Mode.

· If all aspects of Outlook / Exchange Synchronization and the SalesOutlook Toolbar features are all functioning as expected, then the setup process is complete and the computer can be returned to its user.  If this is the case, check the box below to indicate that the computer is ready to be delivered to the user.  Otherwise, troubleshoot the issues and resolve them before returning the computer to the user.
Tip – The SalesOutlook Online KB contains a wealth of troubleshooting and problem-solving information.  If you do not have a login, you can create one by clicking the Register button at the top of a page on the www.salesoutlook.net web site.  
Note:  Registration is an automated two-step process: 
1) create your login account, and 
2) activate the login for use using the instructions and activation code our automated systems send to you via email when you complete the first step.  
After activating your login, proceed to the login page at www.salesoutlook.net/login.asp.  Login, and then proceed to the Support Center and the Support Toolbox.  You will be able to access the SalesOutlook Knowledgebase there.
· Outlook 2007 users in cache mode can utilize Windows Desktop Search. Make sure Outlook is indexing your database Tools | Instant Search | Search options. You may have to rebuild your indexing database Controls Panel | Indexing Options | Advanced | Rebuild. Once the database is built then you will be able to use SalesOutlook in the fastest mode. Tools | Instant Search | Indexing status
· Setup is complete.  Deliver the PC to the user.
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